Help! White Fuzzy Algae.

Daniel

New member
Hello Friends, any idea what is it?
And what can I do to rid off my tank?

Parameters are ok. The only thing I did diferent is dosing dosing AB+ Red Sea energy. Maybe is giving the energy for this algae. I will stop using for a while, scrub the algae and water changes.

But I’d love to know if could be any other thing.

Yes the tank is close to the kitchen for about 2 years but never had this before, also I will avoid candles or clean products in that area.

Thank you all :)







Sent from my iPhone using Tapatalk
 

CF2

Member
What does "ok parameters" mean to you? The first step is to eliminate all of the easy variables, i.e. temp, salinity, nitrate, phosphate, calcium and alkalinity. It also looks like your rock isn't really healthy live rock to begin with (from what we can see in the pics). No coralline algae or anything else growing on it. The algae looks like something that usually appears when you start a tank.
 

Daniel

New member
Temp 77
Nitrate 0.2
Nitrite 0.2
Phosphate 0.03
Alkalinity 8.2
Ph 8.3
Calcium 450
Mag 1400
Salinity 1026

Tank is around 3 months. It was a 2 years old, but I have a big crash when I was traveling and Restarted from Zero again.

Thanks guys.


Sent from my iPhone using Tapatalk
 

CF2

Member
That's what I suspected. The algae looks like the type of algae that appears when cycling a tank. it will probably go away by itself and be replaced by normal algae. Your levels are ok except you shouldn't have any nitrite. (Also wondering what kit you are using that tests .2ppm nitrate?) Are you sure you don't have any ammonia in the tank? Either way the situation will probably resolve itself in the next 1-2 months.
 

Daniel

New member
Thanks CF2. There is no Ammonia in the tank. I try to keep low levels of nutrients, I got 4 fish for a while, 2 clows, 1 wrasse, 1 blue tang.
The tests are Red Sea and Hanna.


Sent from my iPhone using Tapatalk
 
Top